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Bromcom MIS End of Year Procedure 
 
 
THE EXAMPLES AND SCREENSHOTS IN THIS GUIDE ARE FOR ILLUSTRATION PURPOSES ONLY AND MAY DIFFER TO 
YOUR SCHOOL 
 
Basic Guidelines 
 
Make sure that you have the necessary permissions to all the relevant menu items. An Administrator will have access 
by default 
 

This procedure can be undertaken at any point in the current Academic Year, but it is best to wait until the 
information that you are entering is no longer subject to change. 
 
There is no End of Year application to be run as such. The End of Year procedure consists of creating and configuring 
the various Curriculum and Calendar components that make up the forthcoming Academic School Year. Follow all 
the steps appropriate for your system, in sequence. 
 
Preparing for the End-of-Year  

It is recommended that you first tidy up the current Academic Year.  

Check with your colleagues what they want to carry through from the current Academic Year to the next.  

• Will the Heads of Year (or their equivalent) and other staff associated with the Year, be promoted with their 
Year Group? 

• What will this year’s Tutor Groups be called next year? Will they have the same House, Staff and/or Room 
associated with them?  

• Have you checked the end dates of your current Classes and Tutor Groups? All Teaching Classes must have an 
end date before the end of the current academic year. If you need to edit your Teaching Classes and group 
end dates, please read the following guide: How to bulk edit group end dates. If your Tutor Group names are 
changing, then they must have an end date before the start of the next academic year. If they are staying the 
same and being reused, then there is no need to add end dates to your Tutor Groups. Please Note: If you are 
using Google/Office 365 Integration you MUST End Date all Tutor Groups. 

 
 
 
 
 
 
 
 
  

https://docs.bromcom.com/knowledge-base/how-to-bulk-group-end-dates/
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Interval Setting for the End-of-Year.  

 
Ensure your Current Interval on the My Account page is set to Nucleus, that way you will have access to all Academic 
Years including the new one when you create it.  

To change this setting, click on your Profile Menu in the top right of your Bromcom screen and then click on My 
Account in the dropdown menu. 

 

The Interval can be changed to Nucleus, if needed, within the General Panel using the Current Interval drop down.  
Click Save in the top left hand corner. 

 
 The list of Current Intervals you see in the above screenshot are what we call Data Boundaries. 
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Data Boundaries 

You may find using a Data Boundary (also known as an Interval) helpful during the end of year process, as it 
enables you to work within the date range of the new academic year alone. Therefore, any changes you make will 
not have an effect on the current academic year. This is particularly useful/important when making changes to 
areas such as Behaviour and Curriculum for example. 

• Behaviour Detentions: as there is no date range within detentions. I.e., you cannot say that you want a 
detention schedule used for this point in time in the future. If you are making changes to configurations at 
the End Of Year ready for September, then any changes you make to the detention schedules happen 
immediately, which would affect any detentions in July. The way to avoid this is to put yourself in a Data 
Boundary for next academic year, make your changes and then return back to the Nucleus afterwards. 

• Timetable: you may wish to work in a Data Boundary for the new academic year to easily work with next years 
classes rather than having to alter the active on date in various screens, etc. 

• Census: You may need to use a data boundary if you need to update a previous years Learner Funding and 

Monitoring hours. 

 
You can create a Data Boundary via Config>Setup>Data Boundaries 
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For more information see How to Manage Data Boundaries 

 
If you decide to use a Data Boundary, once you have created it for 2025/2026 you can associate this to your user 
Account via My Account>General>Current Interval.  
 
Once you have completed your changes to the new academic year, please ensure you remove this data boundary 
and set your account back to using the Nucleus interval to avoid any issues going forward. 

 Creating a New Period Structure 
 
You only need to complete this section if you plan to use a DIFFERENT Period Structure next year, for example if you 
are changing the shape of the school day or moving to a 2-week timetable, etc. Otherwise, you can skip this step and 
continue to Creating a New Academic Year . 

 

 
Go to Config>Curriculum>Configurations.  

This will open the Defaults for Period Durations panel. Check these and if necessary, adjust them. 
 
Set the global configurations for: AM, PM, and Class Periods 

 

IMP0RTANT: If you use detentions and you create a new period structure, you will need to set up the 
detention scheduling again for the new academic year. See How to Schedule Detentions 

https://docs.bromcom.com/knowledge-base/how-to-manage-data-boundaries/
https://docs.bromcom.com/knowledge-base/how-to-create-a-new-detention-schedule/
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Click on SAVE to save any changes.  
 
Then go to Config>Curriculum>Period Structures and click on the New button.  

 
This will open the Create Period Structure page. Below is an example of what a 1-week Period Structure may look 
like. 
 

 
 

• Period Structure Name*: Give your new structure a name which must be unique, for example 1 Week 6 Period. 
 

• Morning Begins*/Afternoon Begins*: Set the start time of the morning and afternoon sessions; this will be the 
time the first session of the morning and afternoon begin. This will be the AM and PM Registration sessions. 
 

• No of weeks: Set the number of weeks (using the drop-down choices) that will exist in your Timetable Cycle for 
example, a 10-day timetable cycle that runs Monday-Friday is a 2-week cycle (Monday to Friday week 1, followed 
by Monday to Friday week 2).  
 

Don’t worry - Any changes made on this screen will not affect the current year’s data. 
 

The Class Duration refers to the length of the Period and the Max Class Duration refers to the maximum 
length a Period can be. For example, each Period of the day may have a duration of 40 minutes, but the last 
Period on Friday may be 60 minutes. Therefore, the Class Duration would be 40 and the Max Class Duration 
would be 60, allowing for a Period up to 60 minutes. 
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• Days of the Week: Once you have selected the number of weeks, you should put a tick in the boxes of the days 
that are part of the cycle to mark them as Academic Days. 

 
 
 
Below is an example of what a 2-week Period Structure may look like. 
 

 
 
Enter the number of Days in Timetable Cycle* 

 

 
 
Available From*: If you are performing your End of Year process before the start of your new Academic Year, the date can 
be left as today's date (it will not affect the current Academic Calendar), as it will allow changes to be made. If a later 
date is used, you will not be able to see this model until the date entered. Click on the Next button. 
 

 
 

 
Click the Add button to increase the number of available Periods – and use the Period Type dropdown menu to 
select the type of Period. 
 

• BR = Break  

• LU= Lunch 

• AS = After School 

The Days in the timetable cycle* box should usually contain the number of Academic Days in your 
timetable cycle as defined above (e.g., 10 in the example above). It can sometimes be different so if you are 
unsure of what to put in this field then please contact the Helpdesk for advice. 

Once you click on Next, this will open the Create Timetable Day Structure page where you create the 
Period Structure of the day, including the AM position and duration, number of morning sessions, PM 
position and duration, Lunches and Breaks etc. 
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• PS = Pre School 

• AM, PM = Registration 

• TP = Teaching Period 
 
Note: new Periods added will default to TP (Teaching Period) but can be changed using the dropdown. You can edit 
the duration of each session, and the times will adjust but please note that the times must not overlap. 

 
 

 
 

 

RECOMMENDED! 
 

Please define your Breaks (BR), Lunch (LU), Pre-School (PS) and After School Sessions 
(AS). You will need them if you want to schedule detentions outside of normal 
teaching periods (e.g., after school) or you if want to timetable a teacher to do 
lunchtime duty. 

Please remember to adhere to the Period durations set in the configurations earlier on, as well as 
the morning and afternoon begin times. 

You must have an AM and PM session for each day within your period structure, even if students 
don’t attend morning and/or afternoon registration. If you are unsure about this, please contact 
the Bromcom Helpdesk. 
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The checkbox to Copy settings to all days of the Timetable Cycle is to save you having to set this up for each day 
where it is the same as Day 1. Tick this box and then the completed day is then copied to all the days in your Timetable 
Cycle.  

 

If one day of the cycle is different e.g., you finish early on a Friday for Staff Meetings, then amend the appropriate 
days (Days 5 and 10 in this case as we have a 2 Week Timetable). 

 
Once you have completed building your Period Structure, click the Save button if the settings are correct.  
 
You will then be automatically returned to the Period Structures Page, where you can then edit the new Period 
Structure to re-name the Periods if required. 

 

 
 
 
For more information see How to Create a New Period Structure.  

If you have made changes to your period structure for the new Academic Year, then please check to ensure 
all the parameters under Config>Attendance>Register Update Parameters are still valid. For instance, it 
would be difficult to update the PM register from Period 5 if your structure has changed as such that there 
is no longer a Period 5.  

 

https://docs.bromcom.com/knowledge-base/how-to-create-a-new-period-structure/
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Creating a New Academic Year 
 

To ensure that the system continues to run smoothly as you enter the new Academic Year, it is important that you 
define the new Academic Year. 
 

 
 

 
 

Go to Config>Curriculum>Academic Years. 
 

 
 
 
 
 
 
 
 
 
 

The system will automatically check for the End date of the current year and will automatically set the 
start date of the forthcoming year to the day immediately following this date. This is correct and don't 
worry if your first academic day is sometime after this as you will be able to set that later. 

The End Date of the current academic year may need changing. All Bromcom calendar weeks need to 
begin on a Sunday and end on a Saturday. This year the last Saturday in August is the 30th. 
 
To change the forthcoming year’s, Start Date you need to edit the current Academic Year End Date 
 
Note – When amending the end date of the current Academic Year, it can take a while to save. 
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Ensure the current Academic Year is selected from the Academic Year drop down.  
 

 
 

In the Edit Academic Year screen, the End Date must be a Saturday. 

 

 
 
 

 
If you need to make an amendment, choose the relevant date from the calendar picker then click Save, top left.  
 
  

For example, if the new academic year starts on Sunday 31st August 2025, then the End Date of the previous 
year must be Saturday 30th August 2025. 
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To set up the New Academic Year, go to Config>Curriculum>Academic Years. 
 

Click on the top left New button. 

You are now creating your New 2025/25 Academic Calendar. Check the New Academic Years End Date and change 
if necessary, this MUST BE a Saturday.  
 
For most Customers this would be Saturday 29th August 2026. Please see below for an example of how the 2025/26 
Academic Year Start Date* and End Date* could look. 

 
  Select the required Number of Terms* from the dropdown list. 
 

 

 
 
For each term fill in the Term Name*, Start Date* and End Date*. These must follow the logic of:  
Sunday = Start Date and Saturday = End Date 
 
 

We highly recommend that you include the different holidays in your terms and use the Academic Days 
page to mark those holidays as the relevant day status.  
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Please see below for an example of how the New 2025/26 Academic year could look. Note there are no gaps in the 
End Date* and Start Date* of each Term. 

 
 

 
 

Now select the Period Structure that you are using from the dropdown list. If you have defined a new Period 
Structure in Step 1 of the End of Year process, then select this here, otherwise you can choose the structure from 
the current year. In this example we have chosen the ‘Current’ Period Structure. 
 

 
You can (if you wish) change the colour associated with the Academic Year, which will change the text colour on the 
Academic Days screen, by selecting the Colour Code button. 
 
Finally, when picking the Timetable day for first weekday of Term 1 always select 1 as this value determines what 
day in the week the Day 1 will be, for example if 2 is selected here Tuesday will be Day 1, rather than Monday. 
 
Review your settings and then click on the Create button. 

 
 

You have now created the New Academic Year. 

Do not worry if your first Academic Day (the date the students start) or end of terms do not adhere to 
these dates completely, you will get the chance to Edit Academic Days in the next stages. 

The process may take a few minutes to create all the calendar entries. 
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Edit Academic Days 
 
Go to Config>Curriculum>Academic Days to now begin editing the days within your new academic year to include 
holidays, inset days and staff only days.  
 

 
From the Academic Year drop down choose 25/26 

In Key and Display Options the Period Structure you have chosen for 2025/26 will be displayed as per the example 
image below, highlighted within the red box 
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Click on the right-hand drop-down Arrow in each Term to expand the individual weeks in that Term. 
 
Then click the Edit button on the right of the screen to edit the individual days. 

 
Then set each individual day’s Day Status using the drop down choices for AM and PM, this includes staff only days, 
school holidays and public holidays. 
 
In the example below Monday 1st September 2025 has been set as $ Staff Only 
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Normally, the standard timetable day cycle will be a logical numeric progression (1, 2, 3, 4, etc…) but there may be 
deviations from this that need to be accounted for. If they exist, then simply select the week containing the 
adjustment and change the value in the dropdown against that day (you can view Timetable Days by clicking the 
Display Timetable Days option). 
 
Generally, Days 1-5 are Week 1, Days 6-10 are Week 2. 
 
If you have a multi-week timetable, it is critical to ensure that the Timetable Week numberings are correct. This is 
to ensure your timetable is consistent for the rest of the coming year. Check the timetable days are correct by 
clicking the appropriate week number after each half term/new term. Please see an example screenshot showing 
the multi-week timetable. 
 

 
 

In some Local Authorities the attendance teams are no longer accepting $ (our ‘Staff Only’ symbol) in 
Student Attendance Certificates. If you are unsure which code to use, consult with your Local Authority.  
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Tip: If you are amending your Academic Days or have used Cascade Timetable on Save, tick Display Timetable 
Days and Display Week Labels to view/ensure that your Academic Days are correct (Days 1-5 are in Week 1 and 
Days 6-10 are in Week 2). 
 
When you are happy click Save. 
 
Once you have set the specific day details for each term then you have completed the Academic Year setup  
 
 
 
 
 
 
 
 
 
 
 
 
 

Cascade Timetable on Save: Use the Cascade Timetable on Save option when working with a two-
week timetable and you need to insert a holiday. Set all days and sessions in the relevant holiday 
week(s) to the appropriate Holiday status code, then Save those weeks. Next, edit the week when 
students return to school. Assign the correct timetable days to each day (e.g. Days 1-5 for Week 1 or 
Days 6-10 for Week 2.) Before saving, enable the Cascade option. This ensures the correct timetable 
sequence continues from the return date onward for the rest of the year.  

Note: If you skip the cascade step, the system will include the holiday weeks in the timetable sequence. 
This could result in students returning on the wrong timetable week.  
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MCAS General Settings 
 
If you use MyChildAtSchool, go to Config>MyChildAtSchool>General Settings. 
 

 
Once on this page, you need to ensure the new Academic Year will be visible to parents. 
 
If you have All selected in Academic Year to display in MCAS, then you do not need to do anything here. 
 

If you have the User Defined option selected, then ensure the new 2025/26 Academic Year and any previous 
Academic Years that are to be displayed are ticked. 
 
Click on Save 
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Altering Attendance Codes 
 

 
To make any amendments or to create new Attendance Codes, go to Config>Attendance>Attendance Codes and 
set the Academic Year dropdown to 25/26 
 

 
Select the New button if you want to create a fresh Attendance Code. 

Otherwise click the Edit icon to make changes to an existing Code. 
 

 
 
For more information see How to Create and Manage Attendance Codes 

 

Do not change your Attendance Codes if you are adhering to your Education Authorities approved 
list of set Attendance Codes 

https://docs.bromcom.com/knowledge-base/how-to-create-manage-attendance-codes-marks/
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Setting Registration Update Parameters 
 

 
 

Go to Config>Attendance>Register Update Parameters. 
 

Change the Single Date radio button to the Multiple Dates radio button.  
 
Set your Academic Start* to the first Academic day for the new Academic Year and Academic End* to the last academic 
day of the year. 
 

In the example below a 2-week timetable is shown by the Week 1 and Week 2. 
 

 
 
Select the relevant options for your Register Update Parameters. Below is an example of how this might look. 
 

This step is required for all schools where students do not attend AM and/or PM registration and 
therefore need marks from teaching periods to write back into the AM/PM Sessions.  
 
If this step is not completed, none of the expected automatic updates of AM/PM attendance from 
other periods will occur. Therefore, it is imperative that it is finished in its entirety. 



 
Secondary End of Year 2024-2025 Guide 

20 
 

 

 

If you are changing the Period Structure for the new Academic Year, then this screen will require careful 
configuration. To this end it is recommended that you contact the Helpdesk to assist you in configuring these 
additional options if you are unsure. See How to use Register Update Parameters. 
 
If you receive the following warning whilst setting up this page; 'Warning: inconsistent data found in database', it 
should disappear once you have completed all appropriate parameters, however please contact the Helpdesk if this 
is not the case.  
 
Once you are happy with any changes you have made, click on the Save button. 

 
  

If your forthcoming year's structure has not changed, simply click on the Last Available Settings button at 
the top left of the screen and then click on Save. 

 

https://docs.bromcom.com/knowledge-base/how-to-use-register-update-parameters/
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Maintenance of Curriculum Entities 
 
This is where you would change your Curriculum information such as Year Groups, Subjects, Departments, Faculties, 
Houses, Learning Aims etc. if required. 

 
If you are not making changes to these settings then you can skip to the next section, otherwise please read on. 
 
Houses – if you are introducing a House system or changing the way it is organised, go to Groups>Group 
Type>House. 
 
To create a new House with a start date of the beginning of the new Academic Year click on the New button.  

 

Enter the new House details and click on the Save button. 
 
To edit the existing Houses, select the Houses and click on the View button.  
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If you make any amendments, remember to click Save in the top left. 
 
Subjects, Departments and Faculties will normally continue through from year to year.  
 
If any are not in use for the next year, they can be edited by pressing View and entering an End Date within the Basic 
Details Panel (see example screenshot below). Memberships of Staff, as well as the addition of Subjects to 
Departments, and Departments to Faculties can also be amended to reflect the situation for next year. Otherwise, 
they continue through unchanged provided there are no end dates applied e.g., if a member of staff leaves and this 
sets an end date to all their memberships. Once you’re happy Click Save. 

 

 

 
 
 

If a group will no longer be continuing into the new academic year, we advise that you DO NOT DELETE 
the group, always ADD AN END DATE to make it inactive going forward. This will ensure that you can 

report back historically if you need to 
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Student Learning AIMS – Post 16 
 
For Student Learning Aims that are continuing from the Current Academic Year to the new Academic Year please 
check the planned end dates go through into the new Academic Year.  
 
If a Course is ending, then the related Student Learning Aims also need to be ended.  
 
This can be done through Modules>Curriculum>Bulk Learning Aim Update. 

You can select to update the Learning Aims by Student, Class, or Learning Aim.  
 
Once you have made your selection, simply click on the Apply button and this will take you to the next stage of the 
process.  

 

IMPORTANT: In all instances, please remember to double check any entered Start or End dates to ensure that 
they correctly match the appropriate dates from either the Current Year (in the case of items being ended) or 
the forthcoming Academic Year (in the case of new items being added). 
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On the next page you will see the selected Students with All of their related Learning Aims. 
 

 
Please check/amend the relevant end dates/statuses and then click on the Save button. 
 
You will need to repeat this process for any Learning Aims that need to have a different Status or different End 
Date applied. If you have any problems with this process, please contact the Helpdesk.  

 
 

If you use Behaviour, please continue to the next section. Otherwise, please proceed to Promoting Year Groups. 
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Behaviour 
 
Complete this section if your Behaviour Setup needs updating for the upcoming Academic year, or if you are using 
Pathways and need to reset/start a new points total for Student Actions. 
 

 
 

Any Behaviour Events/Actions that will not be used in the forthcoming Academic Year should be expired. 
 
For Behaviour Actions go to Config>Behaviour>Actions and for Events go to Config>Behaviour>Events.  
 
To expire an Action or Event, you have two options: 
 
Expire Immediately: Select the Action(s) or Event(s) and click the Expire button at the top of the page to end date 
it straight away. 
 
Set a Future End Date: Select the Action(s) or Event(s), click Edit, and manually enter the desired end date.  
 

 

 
  

 
 
 
 

Reconfiguration of Behaviour is only required if you use the Behaviour module, and you ARE changing your 
Behaviour setup in the forthcoming year (this includes removing or adding new Events or Actions) 

Expiring an Event or Action only removes it from the system from that date onwards. Historically it will 
still be available and prior instances where they were used will still be retained.  
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Pathways 
 
Any new Events or Actions need to be created in the MIS via the Behaviour module before you can use them in 
Behaviour Pathways. 
 
If you are setting up a New Behaviour Model in Pathways that is different to your current Model go to 
Config>Behaviour>Pathways. 
 
IMPORTANT: Select the required future Date for the new model on the top of the screen, example below. 

 
If you are creating a new Model, use the Actions drop down and choose Clear Board. 
 

 
You will need to do this for each Category that requires replacing. 
 
After this, simply setup the new Behaviour Pathways following the normal instructions. Once you’re happy ensure 
that you click Save.  
 

Starting a New Points Total 
 

 
Go to Modules>Behaviour>Reset Student Actions. 
 
Select the Start New Points Total option. 
 

Starting new points totals is extremely important; If not completed, then all of next year’s points will simply be 
added to the current year’s points totals 
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Enter the Day Start date to start the new totals from (most likely the first Sunday of the new Academic Year). 

 
If you want to start a new Points Total for all Students and all actions, select the ‘All Students’ option, then click on 
the blue spy glass next to the Action Name field and select all actions. Now click Apply in the top left corner of the 
page. 
 
If you are not starting a new Points Total for all Students and all Actions, then do the following: 
 
Select the Students you want to start new point totals for by selecting either Student or Group and select the 
Students or Groups you wish to Start New Points Total for. 
 
Select the Actions you are starting new Points Totals for from Action Name and check the Selection List is correct. 
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Click Apply. You will get a warning message prompt. Click the Proceed button to continue. 

 
Detention Types 

 

 

 

 
 

 

Note: In order to make any changes to Detention Types in the New Academic Year, wait until the day after the last 
day in the final term of the current academic year, then use a Data Boundary for the Next Academic Year to update 
the Detention Type. 

 

IMPORTANT: We recommend that you also review/update your Detention Schedules for each of your 
Detention Types, especially if you have changed your Period Structure for the new Academic Year.  

For more information see How to Create a Detention Schedule 

 

https://docs.bromcom.com/knowledge-base/how-to-create-a-new-detention-schedule/
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Promoting Year Groups 
 
Before we do any form of Promotion for the Year Groups, we need to ensure that each Year Group has a Next Year 
Group linked to it.  
 
This can be done by going to Groups>Group Type=Year Group>select your Year Groups (you can select more than 
one)  

Then click View. 
 

Look in the Additional Group Details section and make sure that the Next Year Group drop down has the correct 
Year Group selected. Once you have entered the next Year Group you will be able to press Save and then click on 
the Next button to take you to the next Year Group if you have selected more than one Year Group 
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If your Year Groups already have the next Year Group entered, please skip this stage. 
 

 

Please see the table below for guidance on how to set your Current and Next Year Groups. If you have Year Groups 
outside of this list and are not sure what the Next Year Group should be, please contact whoever you contact for 
support.  
 

 

Current NC year Current NC Year Name Next Year Group 

7 Year 7 8 

8 Year 8 9 

9 Year 9 10 

10 Year 10 11 

11 Year 11 12  

12 Year 12 13 

13 Year 13 13 (13 must have a Next Year Group in secondary 
schools) 

? <NOT SELECTED> ? 

 
When you are ready to Promote your Year Groups, go to Config>Curriculum>Year Group Promotion. 
 

 
 
 
The Year Group Promotion page will then be displayed. 

Year Groups continue so don't worry about the start and end dates. Note: It is not possible to amend the 
start and end dates for Year Groups 
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Promote from will be set to the current year by default, or last year if you are doing this in September.  
There are two options on the following dropdown menu: 
 

• Add to any existing Memberships preserves any memberships that may have been added to the Year Group for 
next year by other means, for example a new student that has been added to the system manually with a future 
start date in September. 
 

• Overwrite all existing memberships will delete any existing memberships in the year group for next year and 
replace with those being promoted. 

 

There are two additional checkboxes tick these to: 
 

• Create Bands matching those in the Current Year, including Memberships.  

• Include staff memberships e.g., Head of Years, where Head of Years are moving up with the Year Group. If you 
do not include Staff, if their Membership in the group is set to Track Group End Date, then their Membership in 

the group will continue in the same Year Group (i.e. they will not move up with the students). Otherwise, their 
association with the Year Group ends at the end at their assigned End Date. 

 
Clicking on the top left OK button will Promote ALL of your Year Groups. 
 
Important: For a further in depth look at Year Group Promotion please refer to the following guide How to Approach 
Year Group and Tutor Group Promotion 
 

Finally, the Active On selector allows you to pick the date that Year Group memberships will be taken and 
promoted from.  
 
It is CRUCIAL that this is set to a Date in the CURRENT Academic Year before September, when the Students 
are still in their CURRENT Year Groups.  
 
This allows the Students to be Promoted into the correct/next Year Groups in the new Academic Year. 
Promoting from a Date in the new Academic Year will not work, the Active On Date must in the 24/25 
Academic Year. 
 

https://docs.bromcom.com/knowledge-base/how-to-approach-year-group-and-tutor-group-promotion/
https://docs.bromcom.com/knowledge-base/how-to-approach-year-group-and-tutor-group-promotion/
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Promoting Tutor Groups 
 

Google/O365 Integration 
If you are using Google/O365 Integration, then you must End Date all Tutor Groups. 
 

Mixed/Vertical Tutor Group 
You do not need to promote Mixed/Vertical Tutor Groups, the Groups can remain unchanged without an End Date.  
 
Student Memberships can be amended via the Student Memberships panel of the Tutor Group itself. The 
memberships can be transferred to a new Tutor Group with the relevant future start date via the Actions column to 
the right-hand side. 
 

Mixed/Vertical Tutor Groups 
You do not need to promote Mixed/Vertical Tutor Groups, the Groups can remain unchanged without an End Date.  
  
Student Memberships can be amended via the Student Memberships panel of the Tutor Group itself. The 
memberships can be transferred to a new Tutor Group with the relevant future start date via the Actions column to 
the right-hand side. 
 

Non-Mixed Tutor Groups 
 
Tutor Group Names remaining the same - your tutor groups can be left without an end date so the groups remain 
active year on year allowing student memberships to be promoted. 
 
Tutor Group Names changing - your tutor groups must be end dated and new tutor groups created for the new 
academic year. Student memberships can then be promoted. 
 

 
See the flowchart below for more information on Promoting Tutor Groups. 

 

IF your current 24/25 Tutor Groups are ending, and you are not going to continue using the SAME groups 
next year then please ensure that they have an End Date that is BEFORE the Start Date of the New Academic 
Year and that these Dates do not overlap 
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To Promote Tutor Groups, go to Config>Curriculum>Tutor Group Promotion  

 
Click the blue spy glass, this will open the Group Selector list where you can select the Tutor Groups you wish to 
Promote. 

 
Click on the Tutor Groups you wish to Promote in the Group Selector list and click Done. 
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Then click Go. 
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In Tutor Group Linkages click the Tutor Groups you wish to Promote (they will colour blue) and either click on the 
Generate button for the system to suggest a name for the Next Tutor Group OR alternatively type in the Next Tutor 
Group name yourself.  

 
IMPORTANT: Please keep in mind that this process will create brand new tutor groups if it cannot find an existing 
group with the same name. Therefore, if your tutor group names are remaining unchanged with no end date, please 
ensure that the names added into the next tutor group field match exactly. 
 

The changes can either be saved by clicking on the Save button and promoted later, or you can move straight to the 
next step and click Promote to continue. 
 
In the next screen you can choose to exclude any of the Groups by deleting them from the list using the Red Delete 
button. 
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Select the Academic Year you will Promote To from the dropdown list and set the appropriate Start Date and End 
Date you wish to give your Student Memberships for the next Academic Year. 
 

 
 
As with Year Groups you can Add to existing memberships (default for safety) or Overwrite all existing memberships 
(if promoting to pre-existing Tutor Groups please be aware that the overwrite feature will remove all current 
memberships that exist within the date range set above).  
 
Other memberships can be passed on as well: 

• Maintain House Memberships   

• Include Staff Memberships   

• Include Rooms 

 
 

 
 
 
 

Clicking on the Go button will create new group memberships based on the groups they were being promoted from, 
and the old memberships will be given an end date at the end of the current academic year if they did not already 
have one. 

 

 

 

 

 

Hint: If you plan to merge two Tutor Groups (e.g., 11A1 and 11A2 into 12A), note that you cannot 
assign both to the same new group name in a single promotion round - duplicate names are restricted 
for safety reasons. Instead, promote one group first, then run a second promotion to move the other 
group into the same new Tutor Group. 
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Important: For a further in depth look at Tutor Group Promotion, please refer to the following guide – How to 
approach Year Group and Tutor Group Promotion 

 

Adding Tutors to Tutor Groups 
 
In this section, you will learn how to assign Tutors to Tutor Groups and set up the group’s timetable. Once 
completed, Tutors will be able to access their Teacher Dashboard 
 
From the left Menu go to Groups and change the Group Type to Tutor Group (in a Secondary School this will 
default to Teaching Class). 
 

 
Next, select a Tutor Group so it is highlighted blue and then click on the View button, you can choose more than 

one Tutor Group and click Next to move through several groups. 

 
If you are adding a Tutor to a Tutor Group, you need to first ensure that the required staff are visible in 
the Associated Staff panel. 

 
To add a new member of staff click Add New Record in Associated Staff. 

 

https://docs.bromcom.com/knowledge-base/how-to-approach-year-group-and-tutor-group-promotion/
https://docs.bromcom.com/knowledge-base/how-to-approach-year-group-and-tutor-group-promotion/
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Once you have added the required Associated Staff and the appropriate dates click the far-right tick icon under 
Actions. 

 
Remember to click the top left Save. 
 
Important: Once you have added your tutors to your tutor groups you can then generate the AM/PM timetables 
for the new academic year. For more information please see How to Use theTutor Group Timetable Generator 

Shared Groups:  

• If a group is shared between multiple staff you will need to create the timetables manually by using the 
Associated Timetable Panel. See Guidance Below.  

• IMPORTANT: Remember to untick the No 10 in Config > Setup > Daily Maintenance Settings for this 
scenario, so the system doesn’t update overnight and assign all staff to al days/sessions. See our guide on 
Daily Maintenance Settings 

Once all the required Staff have been added, scroll down to find the Associated Timetable Panel.  

This panel shows which Staff are assigned on which dates for which sessions, this in effect creates the Lessons 
Dashboard for the staff. 

To Add a Member of Staff to Multiple Sessions in the Associated Timetable Panel click Add Multiple, which allows 
you to add a staff member to multiple periods in one process. 
 

 
Pressing Add Multiple opens the following pop out window. 
 
Select the Staff* and Room* that you wish to add periods for, you can now either use the table at the bottom of 
the screen to add individual periods, or press Add Multiple Periods. 

https://docs.bromcom.com/knowledge-base/how-to-use-tutor-group-timetable-generator/
https://docs.bromcom.com/knowledge-base/daily-maintenance-settings-overview/
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Note: Only Staff and Rooms that are already Associated with the Tutor Group will be available here. 

 
Add Multiple Periods opens another pop out window where you can select all the periods you would like to add 
for the required Start/End Date. 
 
Note: You need to press shift or control on your keyboard while you click on periods to select more than one. 
Pressing Save takes you back to the original pop out window. 

 
 

You can now see all the chosen periods and if you are happy with them, press Save 
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Promoting Classes 

 
Class Promotion isn’t required if assigning your Students to Groups with Bulk Group Assignment see How to Use 
Bulk Group Assignment .  
 
Class Promotion and Bulk Group Assignment are an EITHER/OR process 
 
Choose from ONE of the following processes. 
 
1. Import new Timetable with new groups for next year then use Bulk Group Assignment to assign the Students 

to the new Classes 

https://docs.bromcom.com/knowledge-base/how-to-assign-bulk-group-assignments/
https://docs.bromcom.com/knowledge-base/how-to-assign-bulk-group-assignments/
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2. Import your new Timetable with new groups for next year then use Class Promotion to assign the students 
being very careful to ensure Class Names match EXACTLY 

3. Use Class Promotion to create your classes and assign students to the new classes.   
 
 

Go to Config>Curriculum>Class Promotion, click the blue find icon to select the Classes to be Promoted and click 
on the Go button. 

 
 
Select the classes in the list (they will colour blue when selected) then click on the Generate button for the system 
to suggest a name for the next Class, alternatively type in the new name.  
 
Note: If you are promoting Students into Classes that already exist you MUST ensure the names match EXACTLY. 

 
The changes can either be saved by clicking on the Save button and promoted later, or move straight to the next 
step and click Promote to continue 

 
Select the Academic Year you will Promote To from the dropdown list and set the appropriate Start Date and End 
Date you wish to give your Student Memberships for the next Academic Year. 
 
You can Add to existing memberships (default for safety) or Overwrite all existing memberships. Please be aware 
that the overwrite feature will remove all current memberships that exist within the date range set above).  
 
Other memberships can be passed on as well: 

• Staff   
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• Rooms 

 
Clicking on the Go button will create new group memberships based on the groups they were being promoted from, 
and the old memberships will be given an end date at the end of the current academic year if they did not already 
have one. 
 

 
 

 
Important: If you have imported a timetable, it is crucial to enter the new class names exactly as they appear in the 
timetable. This ensures that the wizard promotes the students into the classes that have already been created by 
the timetable, rather than creating more classes and promoting students into them incorrectly. 
 

Please contact the Helpdesk if you need any assistance with this process 
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Adding New Students 

 
New Students can be added by any or all of the options below 

  

Adding a Student Manually 

Click Students in the left-hand menu, this will open the Students List Page  

 

Tip: Best practice is to check the Student doesn’t already exist in the database by typing their name into the top right 
Search Names box. 

Once you’ve checked the Student doesn’t exist click the top left New button. 
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This will open Create New Student to enter in the new Students information. Note: The Entry Date defaults to 
todays date, amend if required. 

 

 
Group Name, if known either type in the name of the Tutor Group or click the blue spy glass to open the Group 
Selector and choose the required Tutor Group. 
 
House  

• If the Tutor Groups are attached to Houses there is no need to choose the House as it will link from Tutor Group 
Memberships in Groups>House>View>Tutor Group Membership 

• If the Students are attached to Houses in Groups>House>View>Student Membership, then choose the House 
from the dropdown choices 

• Best practice in Groups is to EITHER link Houses to Tutor Groups OR Student Memberships, not both. 
 
Fill in the details and click on the Save button, this will now open the Student Details page on the Profile Tab where 
additional information can be added. All fields marked * must be completed. 
 
For more information see How to Add a Student 
 
 

CTF Import 
 

https://docs.bromcom.com/knowledge-base/how-to-add-a-student/
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Note: You will need a valid CTF file to carry out this process 
 
Click on Students in the left-hand menu to open the Student List page. 
 
Then from the Actions drop down click CTF Import, you do not need to select any Students in the Student List page 
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This will open the CTF Import page. 

Click on the top left Browse button to navigate to the CTF Import file saved to your PC, select it, and click on the 
Open button.  
 
 
For the Complete Missing Data/Overwrite drop down choices;  

 

• Overwriting will replace the data that is present for that Student in the system with the data included in 
the CTF, where the information is different, so should be approached carefully.  
 

• Complete Missing Data will use the CTF data to complete any missing parts of the Student’s record. 
 
Then enter in the date for Enter Admission Date* for when the new Student(s) will be starting. This will default to 
today’s date.  
 
Once you are happy, click on the Next button, check the data, and then click on the Import button to Import the 
Students into the system.  
 
For more information see How to Add/Update Students with a CTF Import 
 

ATF Import 
 

https://docs.bromcom.com/knowledge-base/how-to-add-students-via-ctf-import/
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Go to the Students List page and from the Actions dropdown click on the ATF Import button. 

This will open the ATF Import page. 
 

Click on the top left Browse button to navigate to the ATF Import file saved on your PC, select it, and click on the 
Open button.  
 
Next, select the Pre-Admission Group* you wish to import students in to, this will remove the Enter Admission Date 
box as the Admission Date will be coming from the Admission Date defined in the Pre-Admission Group. 
 
Once you are happy, click on the Import button to Import the Students into the system.  
 
For more information see How to Add Pre Admissions Students using ATF and CTF Imports 
 

Student Leavers 
 
If you have any questions on making Students Leavers, please see the following Guide: How to Process a Leaver  
 
 

https://docs.bromcom.com/knowledge-base/how-to-admit-students-using-atf-and-ctf/
https://docs.bromcom.com/knowledge-base/how-to-process-a-leaver-and-ctf-export/
https://docs.bromcom.com/knowledge-base/how-to-process-a-leaver-and-ctf-export/
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Creating New MyChildAtSchool   
 

Complete this section if you use MyChildAtSchool otherwise, move straight to Data Archiving.  
 

If you use MyChildAtSchool, go to Modules>MyChildAtSchool>User Accounts. 
 

 
From the User Account Maintenance page click New to get to the User Account Creation popup. 

Choose Select Students to see a list of the Students that are not linked to an MCAS Account 
 
Select the required Students and click Next.  
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Important: Manual or Auto: If you are creating several Accounts at the same time, select the Auto radio button. If 
you want to create Accounts for only one Student you can select either Auto or Manual. 
 

 
Once you press Generate, you will receive a success notification and you will see a list of the Contacts who now 
have an MCAS Account, click Send Generate Password Email. 

 
For more information see How to Create New MCAS Accounts. 

 
 
 

https://docs.bromcom.com/knowledge-base/how-to-create-my-child-at-school-user-accounts/
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Creating New Student Portal Accounts 
 
Without Single Sign-On 

Go to Modules>Student Portal>User Accounts  

Once this page loads, any existing Student Portal User Accounts will show on the page as seen on the example 
below.  

In this example, we have started with a blank setup so that the full process can be shown, and a first time set up for 
Student Portal User Accounts is displayed. 

 
Once the User Accounts page loads, it will be blank because there are no existing User Accounts yet. From here, 
press New. 
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Once you press New, this will open a new section where all of the Students without User Accounts are displayed, 
and you have the following options: 

• Current - This option refers to Students who are currently on Roll. 

• Leaver - This option refers to Students who have been processed as Leavers. 

• Future - This option refers to Students who have a future start date/will be joining.  

Set this to Current and it will provide you with all the on-roll Students without accounts yet. 

 

From here, you can either use the Select All option or individually click on the specific Students you want to create 
User Accounts for and press Next.  

 
Once you press Next, this will take you to the account generation page where you can select to Auto or Manually 
Generate the Accounts. 
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It is recommended here to use Auto, especially if you are doing this in bulk. This means that the format of the User 
Accounts is consistent, and the process is more efficient. 

When you are ready press Save. 

Pressing Save takes you to the final step where the Accounts have been created. 

You can choose to Send the Invitation Code Emails at this point or press Close and send the Emails in your own 
time. 
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When you return to Modules>Student Portal>User Accounts, all Students with User Accounts will now be visible. 

If you did not send the Invitation Code Emails in the last step of the process, you can now send the Emails from 
Modules>Student Portal>User Accounts Page under Action as seen below. 

  

 
You will now also see that when you open a Student's Record, the Graduation Cap on the top right of their record 
is now Green. 

Previously this will have been Grey before a User Account was created for them. 

Student without a User Account  

 
 
 
 

When it is Green, you can click on this to preview the Student's Student Portal account. 
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Student with a User Account  
 

 
With Single Sign-on 

If you are creating Student Portal User Accounts and you have enabled the option for Single Sign-On Providers 
within Config>Student Portal>General Settings, then the process is a little different. 

 
When you are on Modules>Student Portal>User Accounts, you will ONLY be able to Import new User Accounts, 

not create them manually. 

To obtain the correct template which allows you to Import User Accounts, use the CSV Button highlighted below.  
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This will export the existing list of User Accounts to your PC as a CSV Download. 

It is crucial that you do not amend the Headings within the file otherwise the Import will not work. 

 
Leave the Headings as they are and populate the fields below them correctly for each Student and save the file. 

Once the data has been entered, you will be able to Import the CSV File on the User Accounts page, which will 
create the User Accounts for you. 

Note: New User Accounts need to be linked to an Office365 or Google Email Address to use Single Sign-On. 

For more information see How to Create Student Portal User Accounts 
 
 

Clubs, Trips & Wraparound Care 
 
Please see below for guidance on best practice when setting up Clubs, Trips and Wraparound Care for the New 
Academic Year. 
 
• To Create your clubs/trips for next year, firstly you must ensure that the new academic year has been 

created (dates and academic days can be changed later if not yet known exactly). See Academic Year in 
this guide.  

https://docs.bromcom.com/knowledge-base/how-to-create-student-portal-user-accounts/
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• For trips ensure that the end date of the group falls after the trip itself takes place, ideally giving 
enough time for all payments to be chased/collected. You may encounter issues if trying to process 
payments once the end date of the group has passed.  

• We recommend removing the Trip from MCAS once all parents required have signed up. This can be done 
by removing the ‘Live on MCAS’ dates within the Additional Group Details panel of the Trip.  

 
Wraparound Care 
When setting up a Wraparound Care (Running Balance) club, we recommend not entering an end date initially. 
This allows the club to be reused across academic years without needing to recreate it each time. 
 
If you decide to close the club in the future, you can do so using the Terminate Club button in the Basic Group 
Details panel. 
 
⚠️ Important: Once an end date  is set, it cannot be removed, meaning you’d need to create a new one – requiring 
any outstanding balances to be manually transferred. By keeping the same club active and simply updating the 
schedule each year, all balances remain in tact and usable.  
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Data Archiving and DMS Storage 
 
This section will assist you with Archiving the oldest Academic Year in your MIS and how to manage the DMS Storage 
linked to your MIS. 
 

Data Archiving  

 

To see the previous Academic Years that have been archived on your system, go to Modules>Setup>Data Archiving. 
It may show nothing if this is the first time you are performing this process. 

 
The Archiving process, and which Academic Year will be processed, will be displayed on the Data Archive 
Configuration page. From here you can also review exactly what will be archived and what will be permanently 
deleted from your MIS. 

 
  

Please note that this process is IRREVERSIBLE so ensure you have reviewed the process carefully 
before completing.  
 
Please call the Helpdesk on 020 8290 7177 if you have any questions. 
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Once you have reviewed and are happy to proceed, you will need to enter your MIS Account Password before clicking 
on the Archive Now button. 
 
The process will run and take you back to the previous screen with a confirmation message at the top of the page. 
This will indicate that the process completed successfully and now you should see the Academic Year you have just 
archived in the Archive Years list. 

 
 

You can also access reports on Archived Data from Reports> Quick Reports and select the Archived Data domain. 
 

DMS Storage 

You should also review your DMS Storage and remove any reports/documents that are no longer needed. Please 
refer to the Managing the DMS guide that is available in the Documentation Centre: How to Manage the DMS. 

 
 
 

This is the end of the End of Year Guide for Secondary School 2024-2025 
 

If you have any issues or queries, please do not hesitate in contacting whoever you 
contact for Support. 

 
  

https://docs.bromcom.com/knowledge-base/managing-the-dms/
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